Return to blogland & battery problems

Somehow, it has been over two months since my last post (appropriately enough, this is starting off sounding like a confession, sans pedophile) and for that I apologize.

I think most of the blame is due to the fact that I can't/don't dare post or even look at the blog while I'm at work, and since historically my posts occurred during breaks at work, that's naturally going to kill my posting rate.  I guess this isn't unreasonable, but it's another reminder of how nice the academia-bubble can be.

The other cause of my lack of posting has been the occurrence of power-system problems with my powerbook.  A little while ago (I guess two months ago) I unplugged my powerbook one day to move into the livingroom and it died.  I hadn't noticed any problems with the battery,  but when I replugged the power cord and booted it back up, I noticed that the battery was at "29%, charged".  Following the instructions for recalibrating the battery, I unplugged the powercord and let it run down until it went to sleep, then took out the battery, poked the PRAM, plugged it back in, and... nothing.  It now says "0 %, fully charged".

Has anybody else encountered problems like this?  Poking around the interwebs it looks as though this is not a terribly uncommon problem, but a clear solution does not exist.  I have considered taking it down to the Apple Store downtown, but so far that's been too much bother.  I hope that the solution is as easy as spending my hard-earned cash on a new battery, but I'm leery of doing that only to discover that my new battery won't charge either.

I think that's enough complaining for now.  More posts to come - I've actually got a whole folder of post-items in my gmail just waiting to be used, although many are now out of date.  Anyway, howdy everybody and it's good to be back.

-m

  

Published by

Michael

"O Whisky! soul o' plays and pranks! Accept a bardie's gratfu' thanks! When wanting thee, what tuneless cranks Are my poor verses! Thou comes-they rattle in their ranks, At ither's a-s!" Robert Burns - "Scotch Drink" 1785

2 thoughts on “Return to blogland & battery problems”

  1. It sounds to me like your battery lost a cell and then went kaput. Lithium laptop batteries are really only supposed to last a year or two before their life is up so it might just be that this one's time had come.

    A few things to check though...
    1. When you press the indicator light on the battery, does it say anything different from what the computer is reporting?
    2. Have you tried zapping the PRAM and resetting the PMU? http://support.apple.com/kb/HT1431?viewlocale=en_US
    3. Have you checked to make sure the battery firmware is correct?
    http://support.apple.com/kb/HT2339

    I'm guessing you need a new battery, but it'd save you $80 if one of the things above fixed the problem.

  2. Okay, good to know. I was a little indignant about it having lasted only about a year, but if you're not surprised by that then I guess I'll suck it up and get a new one... and thanks for the suggestions, but unfortunately PRAM/PMU resets, firmware updates, etc did nothing. I think you're right that it just crapped out.

    Really, this is just a sign that I need a new MacBook... but I will miss Firewire.

Comments are closed.